CVE-2026-66669 PUBLISHED

WordPress Superb Addons: Blocks, Patterns &amp; theme Designer plugin <= 4.2.4 - Cross Site Request Forgery (CSRF) vulnerability

Assigner: Patchstack
Reserved: 27.07.2026 Published: 07.11.2026 Updated: 07.11.2026

Cross-Site Request Forgery (CSRF) vulnerability in Suplugins Superb Addons: Blocks, Patterns & Theme Designer superb-blocks allows Cross Site Request Forgery.This issue affects Superb Addons: Blocks, Patterns & Theme Designer: from n/a through 4.2.4.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS Score: 8.8

Product Status

Vendor Suplugins
Product Superb Addons: Blocks, Patterns &amp; Theme Designer
Versions Default: unaffected
  • affected from 0 to 4.2.4 (incl.)

Solutions

Update the WordPress Superb Addons: Blocks, Patterns & Theme Designer plugin to the latest available version (at least 4.2.5).

Credits

  • nizar yart (D3dC0d) | Patchstack Bug Bounty Program finder

References

Problem Types

  • Cross-Site Request Forgery (CSRF) CWE

Impacts

  • Cross Site Request Forgery