CVE-2026-91049 PUBLISHED

EWWW Image Optimizer 8.7.4 - 8.9.0 - Author+ Stored XSS via 'data-script' Lazy Load Attribute

Assigner: WPScan
Reserved: 14.09.2026 Published: 05.11.2026 Updated: 05.11.2026

The EWWW Image Optimizer WordPress plugin before 8.9.1 does not properly sanitize and restrict a value in post content before using it to dynamically load and execute a script in the page, allowing authenticated attackers with author-level access and above to inject arbitrary web scripts that run in the session of any user who views the affected page, including administrators.

This is an incomplete fix of CVE-2026-15446: the origin and path restrictions added from 8.7.4 onward were each bypassable, so versions 8.7.4 through 8.9.0 remain affected.

Product Status

Vendor Unknown
Product EWWW Image Optimizer
Versions Default: unaffected
  • affected from 8.7.4 to 8.9.1 (excl.)

Credits

  • Charles Vosburgh finder
  • WPScan coordinator

References

Problem Types

  • CWE-79 Cross-Site Scripting (XSS) CWE