CVE-2026-93293 PUBLISHED

Password Protected <= 2.8.4 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Freemius purchase_completed Handler

Assigner: Wordfence
Reserved: 17.09.2026 Published: 29.10.2026 Updated: 29.10.2026

The Password Protected plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the bundled Freemius SDK's purchase-completion handler in all versions up to, and including, 2.8.4 due to insufficient input sanitization and output escaping. Once the site's Freemius opt-in is complete (the normal state after an administrator clicks "Allow & Continue"), the handler processes the 'purchased_plan' request parameter on any wp-admin request from an authenticated user without any capability, nonce, or purchase validation, and stores it in a persistent, site-wide administrative notice. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts that execute automatically when an administrator views a standard admin page such as their Profile page.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 6.4

Product Status

Vendor saadiqbal
Product Password Protected – Protect Your Site Content With a Password
Versions Default: unaffected
  • affected from 0 to 2.8.4 (incl.)

Credits

  • daroo finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE