CVE-2026-9601 PUBLISHED

Stackable <= 3.19.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'save' Parameter

Assigner: Wordfence
Reserved: 26.05.2026 Published: 07.11.2026 Updated: 07.11.2026

The Stackable – Page Builder Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'update_block_style' endpoint in all versions up to, and including, 3.19.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 6.4

Product Status

Vendor bfintal
Product Stackable – Page Builder Gutenberg Blocks
Versions Default: unaffected
  • affected from 0 to 3.19.9 (incl.)

Credits

  • Osvaldo Noe Gonzalez Del Rio (Os) finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE