CVE-2026-96565 PUBLISHED

WP-Members Membership Plugin <= 3.5.7 - Authenticated (Subscriber+) Stored Cross-Site Scripting via WooCommerce Checkout Multicheckbox/Multiselect Field

Assigner: Wordfence
Reserved: 23.09.2026 Published: 07.11.2026 Updated: 07.11.2026

The WP-Members Membership Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via WooCommerce Checkout Multicheckbox/Multiselect Field (scalar bypass of wpmem_sanitize_array) in all versions up to, and including, 3.5.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is only exploitable via the WooCommerce classic checkout path, as the sibling registration, profile, and account-edit handlers implode the value before sanitization, which raises a PHP 8 TypeError on scalar input and fails closed.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 6.4

Product Status

Vendor cbutlerjr
Product WP-Members Membership Plugin
Versions Default: unaffected
  • affected from 0 to 3.5.7 (incl.)

Credits

  • Jacek Sowiński (dzaku) finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE