CVE-2026-97254 PUBLISHED

WordPress Royal Elementor Addons plugin <= 1.7.1069 - Cross Site Scripting (XSS) vulnerability

Assigner: Patchstack
Reserved: 24.09.2026 Published: 26.10.2026 Updated: 26.10.2026

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WProyal Royal Elementor Addons royal-elementor-addons allows Stored XSS.This issue affects Royal Elementor Addons: from n/a through 1.7.1069.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
CVSS Score: 6.5

Product Status

Vendor WProyal
Product Royal Elementor Addons
Versions Default: unaffected
  • affected from 0 to 1.7.1069 (incl.)

Solutions

Update the WordPress Royal Elementor Addons plugin to the latest available version (at least 1.7.1070).

Credits

  • nh4tvd | Patchstack Bug Bounty Program finder

References

Problem Types

  • Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') CWE

Impacts

  • Stored XSS